View Issue Details

IDProjectCategoryView StatusLast Update
00300782.x IDE BugsBuild MacPublic2019-10-09 11:24
ReporterDanAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformmacOSOSmacOS SierraOS Version10.12.3
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030078: Build Mac: Xcode 10 support raised minimum macOS version to 10.12, not 10.7 as expected
DescriptionWe have a report that adding Xcode 10 support in 2.2.0 raised the minimum macOS version required to run games to 10.12, not 10.7 as we expected. This means if a developer makes a non-AppStore build and passes it to their players, those players can no longer run the game on OSX 10.6 - 10.11.

10.6 "correctly" should no longer work, as Xcode will throw errors if we try to build projects which support 10.6, but 10.7-10.11 should all be working.
Steps To Reproduce1. Build a game for non-AppStore macOS using Xcode 10 and High Sierra/Mojave.
2. Run that app on an older OSX.
Tagsosx, Runner
2.x IDE Found In2.2.0.343
2.x Runtime Found In2.2.0.258
2.x IDE Verified In9.2.1.1816
2.x Runtime Verified In9.9.1.1440

Activities

Russell Kay

2018-10-24 15:19

Manager   ~0061851

I could not reproduce this building it myself

Dan

2018-10-29 15:15

Adminstrator   ~0061891

Whilst we did not reproduce the error dialogue and the inability to run games on older OS X versions, we did made a few fixes to the Xcode project file which "should" stop this.