View Issue Details

IDProjectCategoryView StatusLast Update
0030068RunnerFunctionsPublic2019-01-04 16:05
ReporterDanAssigned ToMike Dailly 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
PlatformOSWindows 10OS VersionPro x64
Product Version2.2.0 
Target Version2.2.0Fixed in Version2.2.0 
Summary0030068: Functions: Crash when using get_string_async() and get_integer_async()
DescriptionRuntime v2.2.0.258 has a crash when using get_string_async() and get_integer_async() and clicking either of the OK or Cancel buttons.

This does not reproduced in internal versions, so must have been a temp issue we have since fixed.
Steps To Reproduce1. Run the attached sample for Windows (Android has also been reported).
2. Use the dialog.
3. Observe game hard crashes (no code error is shown).
Repro: 100%
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.0.258
2.x Runtime Verified In2.2.0.259

Activities

Dan

2018-10-04 12:24

Adminstrator  

get_async_bug.yyz (12,684 bytes)

Mike Dailly

2018-10-04 14:01

Developer   ~0061713

Fixed in green

Dan

2018-10-05 15:50

Adminstrator   ~0061718

Windows is fine now. Need to confirm Android.

Dan

2018-10-05 16:51

Adminstrator   ~0061721

Windows, UWP, Android, and HTML5 are all fine now. Closing.

Dan

2018-10-09 12:08

Adminstrator   ~0061735

Last edited: 2018-10-09 12:08

View 2 revisions

Please be aware this was a fairly general memory corruption issue which most commonly presented with async dialogues, but was not limited to that scenario - e.g., we think it's also the reason why a small number of users see crash dialogs on closing Windows games in 2.2.0.258.