View Issue Details

IDProjectCategoryView StatusLast Update
0030060RunnerGeneralPublic2021-08-04 12:32
ReporterDanAssigned ToCoreTech 
PriorityLowSeverityD - MinorReproducibility100%
Status ResolvedResolutionSuspended 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.0 
Target VersionFixed in Version 
Summary0030060: General: Errors accessing resources because the texture/audio group is disabled should be made clearer
DescriptionIf you attempt to draw a sprite which is on a disabled texture page you will simply get "Error attempting to draw sprite sprite0", which doesn't help identify the cause of this error or what the user needs to do to resolve.

Doing this with a sound, you get a more informative but inconsistent: "sndMusic2: Audio Group 1 is not loaded"

Expected: For Sprites you get "Unable to draw [resource name] because its texture group is disabled on this platform" and for Sounds you get "Unable to play [resource name] because its audio group is disabled on this platform"
Steps To Reproduce1. Import the attached sample.
2. Run it for Windows.
3. Observe the output log.

Repro: 100%
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.0.258
2.x Runtime Verified In

Activities

SamH

2021-08-04 12:32

Developer   ~0066621

Have moved to the current bug database now, as still happens in v2.3.3.