View Issue Details

IDProjectCategoryView StatusLast Update
0030037RunnerVariables (In-Built)Public2018-10-25 12:41
ReporterStewart BishopAssigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionInternal Build 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030037: Variables: Enums which references constants throw circular reference error
DescriptionIf you create an enum such as :

enum DefaultKeyboardKeybindings {
    Up = ord("W")
}

Then reference it using another enum such as:

enum CustomKeyboardKeybindings {
    Up = DefaultKeyboardKeybindings.Up
}

Then this will throw the following error: Object: object0 Event: Create at line 12 : enum reference 'DefaultKeyboardKeybindings.Up' is not a constant, part of a circular reference
Steps To Reproduce1) Import the sample
2) Try to run it (e.g., for Windows)
3) See that this fails because of a compiler error
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In9.9.1.1189
2.x Runtime Verified In2.2.1.267

Activities

Stewart Bishop

2018-09-25 16:54

Developer  

EnumTest.yyz (19,739 bytes)

Russell Kay

2018-09-28 11:33

Manager   ~0061663

Fixed in gitlab