View Issue Details

IDProjectCategoryView StatusLast Update
00300302.x IDE BugsGeneralPublic2018-10-17 11:12
ReporterMatthew McInnesAssigned ToAlan Savage 
PriorityMediumSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030030: General: [Mac IDE] Fatal error upon pressing F5 to build whilst project is loading
DescriptionISSUE:

- If you press F5 to build, whilst the project is still loading, a fatal error occurs.
- The issue is easiest to reproduce using the attached projects

EXPECTED:

- All input should be blocked whilst a project is loading
Steps To Reproduce1) Launch IDE v9.2.1.1554 Runtime v9.9.1.1186 on Mac
2) Import or open a large project
3) Whilst the project is loading, press F5 to build
4) Observe fatal error
Additional InformationSee attached ui.log
TagsIDE, mac
2.x IDE Found In9.2.1.1554
2.x Runtime Found In9.9.1.1186
2.x IDE Verified In2.2.1.347
2.x Runtime Verified In2.2.1.262

Relationships

related to 0030058 ClosedAlan Savage General: [Mac IDE] Whilst a project is loading, we don't block certain input, resulting in a crash when opening certain Tools 

Activities

Matthew McInnes

2018-09-20 16:13

Adminstrator  

ui.log (296,227 bytes)

Matthew McInnes

2018-10-17 11:12

Adminstrator   ~0061780

Closing. Verified as fixed in:

IDE v2.2.1.347 Runtime v2.2.1.262