View Issue Details

IDProjectCategoryView StatusLast Update
00300182.x IDE BugsResource TreePublic2018-10-31 11:20
ReporterSteven CampbellAssigned ToSteven Campbell 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0030018: Resource Tree: Custom TreeViews duplicate filtered folder during Add from Default
DescriptionIf you have a custom tree view with one folder, filter to that folder, then add resources from the default view then that folder gets duplicated and the resources "disappear"
Steps To ReproduceCreate a new project
Add some resources
Create a new view ( say "My Folder" )
Create a group ( "My Folder" )
Select Filter Tree in the drop down search options and type "My Folder"
Notice that your tree has My Folder (Filtered) -> My Folder
Right click the "My Folder" group, and select Add From Default View
Drag the resources over to My Folder and notice that it duplicates and due to the filtered view, the resources "disappear"
Repeat as many times as you like.
Additional InformationFor additional fun, once the folder has duplicated, when Adding from Default View, select a previous duplicate and get an unstable error.
Once you unfilter the tree, you'll have multiple nested group entries with the actual resources on the final leaf node.
TagsNo tags attached.
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.1.361
2.x Runtime Verified In2.2.1.273

Activities

Steven Campbell

2018-10-01 10:00

Manager   ~0061682

Fixed in Red IDE/GitHub Pull Request 4301
Git Id: 39ba89563526e35fba5c134133184d71987fe52a