View Issue Details

IDProjectCategoryView StatusLast Update
00300162.x IDE BugsGeneralPublic2018-10-01 15:50
ReporterMatthew McInnesAssigned ToSteven Campbell 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.0 
Target Version2.2.0Fixed in Version2.2.0 
Summary0030016: General: [Mac IDE] CEF fails when it has been used by another application
DescriptionISSUE:

- CEF was not being used as intended on standalone version of GMS2, as it had been used first by Steam version of GMS2

EXPECTED:

- Multiple versions of GMS2 should be able to use CEF concurrently
Steps To Reproduce1) Ensure Mac has both standalone and Steam versions of GMS2 installed
2) Launch the standalone version
3) Attempt to open marketplace, the manual, or run a tutorial
4) Observe black screen
TagsNo tags attached.
2.x IDE Found In2.2.0.338
2.x Runtime Found In2.2.0.256
2.x IDE Verified In2.2.0.34
2.x Runtime Verified In2.2.0.258

Activities

Matthew McInnes

2018-10-01 15:50

Adminstrator   ~0061692

Closing. Verified as fixed in:

IDE v2.2.0.341 Runtime v2.2.0.258

Was able to run the standalone version of GMS2 + the 4 Steam versions, each of them able to have a CEF browser running concurrently.