View Issue Details

IDProjectCategoryView StatusLast Update
00299982.x IDE BugsCompilingPublic2018-10-31 11:26
ReporterKevin BrownAssigned ToSteven Campbell 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSOS Version
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029998: Compiling: Some instances added to room are not functional in the game when it has been built
DescriptionIn the attached project you can see the project is not building correctly causing some assets and objects to not be shown within rooms.

We tried changing the object referenced to another object that is shown in the room on a different layer, and this showed up in-game, but reverting to use obj_top_borderbox restored the issue.

Looks like the compiler has some issue with obj_top_borderbox and any new object that is created, but we're unable to see why this is or if it might be possible to fix the user's project.
Steps To ReproduceOpen the attached project
Open the room "Credits_Screen"
Notice the contents of the "Top_Cover_Hide" layer
Run the project
Notice that the contents of the "Top_Cover_Hide" layer are not shown within the game that is run
Add a copy of the object "obj_back_cover" from the "Bottom_Cover_Hide" layer to the "Top_Cover_Hide" layer
Run the project
Notice that the object "obj_back_cover" is shown
Additional InformationOriginal Zendesk Ticket: https://yoyogames.zendesk.com/agent/tickets/146514
TagsIDE
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.1.361
2.x Runtime Verified In2.2.1.273

Activities

Dan

2018-09-07 10:44

Adminstrator   ~0061544

Project has two "root Views" because of some unknown saving issue. The IDE sees one, the asset compiler sees the other. Adding functionality into the IDE to detect this issue on project load and offer to repair the project for the user.

We can fix the project, so have done so for the user.

Steven Campbell

2018-09-07 11:32

Manager   ~0061551

Fixed in Red IDE/GitHub Pull Request 4275
Git Id: e45708a9cbf3ec9e20f242004bc32b555a4021d0

This actually causes additional issues as the asset compiler could decide to use a different root view than what the IDE presents.
You can then end up with issues like duplicate items, slight differences between items in each view, lost items, and the room order not matching the IDE's display.
The fix is destructive, as it has to merge everything together and will favour the first root it finds in regards to duplicate items - duplicate as in sharing the same GUID which should be the same resource.
The user is warned that the project is unstable and can repair it or continue as-is.

All duplicate and lost items are noted in the ui.log:
[11:10:50:88(d441)] Lost item ( 455d555b-b374-41de-81d9-bff353d102e2 ) found in ( 582bda5b-8491-47a0-8bc1-b2e391935146 - Screen_Content ) and was potentially a GMSprite
[11:10:50:88(d441)] Duplicate item ( ce_logo ) found in ( 3f8feddf-e13f-4448-94d7-c5d4cfc4bd3a - Logos ) and ( 3f8feddf-e13f-4448-94d7-c5d4cfc4bd3a - Logos )