View Issue Details

IDProjectCategoryView StatusLast Update
0029993RunnerHTML5Public2018-10-29 10:46
ReporterStewart BishopAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility<25%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029993: HTML5: audio_sound_gain() has issues applying the correct value when the argument "time" is not 0
Descriptionaudio_sound_gain() works perfectly in HTML5 when the argument "time" is 0 but if it is not the case, you can have issues:
- The way the sound is fading in or out seems to be smoother in Windows than HTML5.
- If you use audio_sound_get_gain after that, you will get unexpected values.

The attached sample fades a sound in and out continuously.
- Run the sample in Windows and see the sound fades in and out as expected. If you press Enter, you will get the sound gain value which is correct.
- Now run the sample in HTML5. Notice the sound seems to fade out more quickly than in Windows. It will also never fade in and if you press Enter, you will get an unexpected value for the sound gain.
Steps To Reproduce1) Run the sample on Windows
2) Run the sample on HTML5
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.1.5.246
2.x Runtime Verified In2.2.1.268

Activities

Stewart Bishop

2018-09-03 12:05

Adminstrator  

soundgainBug.yyz (213,576 bytes)