View Issue Details

IDProjectCategoryView StatusLast Update
00299872.x IDE BugsInstallingPublic2019-05-16 12:04
ReporterDanAssigned ToSteven Campbell 
PriorityVery HighSeverityB - MajorReproducibilityUnable To Reproduce
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029987: Installing: Runtimes can fail to download because drive mappings (typically Z) are not able to be made
DescriptionAfter installing, some users are seeing that their runtimes can fail to download immediately because drive mappings (typically the first drive we try to make - Z:) are not able to be made. This seems to affect users who already have a number of drive mappings in place or have restrictions about being able to make drives with certain letters we then try to use.

These users will see a pause when trying to download the runtimes, then an error dialogue will appear over the splash screen, as shown in the screenshot.

String not found: System.IO.DirectoryNotFOundException
could not find part of the path 'Z:\manifest'
Steps To Reproduce1. Create a number of drive mappings (including Z) manually.
2. Fresh install 2.1.5.
3. Observe if this throws the error above.
TagsNo tags attached.
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.0.334
2.x Runtime Verified In2.2.0.252

Activities

Dan

2018-08-31 10:48

Adminstrator  

Steven Campbell

2018-09-03 10:39

Manager   ~0061475

Fixed in 90c2ff2b7e6cce87ee929e6c144ae061d48749c4 - it'll only use one subst at the root runtime folder.

Matthew McInnes

2018-09-05 10:42

Developer   ~0061510

Closing. Verified as fixed in:

IDE v2.2.0.334 Runtime v2.2.0.252