View Issue Details

IDProjectCategoryView StatusLast Update
00299802.x IDE BugsCode EditorPublic2018-10-29 12:13
ReporterStewart BishopAssigned ToAlan Savage 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029980: Code Editor: Text highlighting doesn't update correctly when you indent some text
DescriptionIf you select a section of text and shift tab it then your text will indent as intended however your text highlighting will stay in the same position.
Steps To Reproduce1) Create a script
2) Write something and indent it
3) Select it using the mouse or keyboard shortcut
4) Shift Tab to indent it to the left
5) See that this has worked but your text highlight hasn't moved
TagsCodeEditor, IDE
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Alan Savage

2018-08-30 16:48

Developer   ~0061411

fixes squiffy selection/cursor position after selection indent