View Issue Details

IDProjectCategoryView StatusLast Update
00299432.x IDE BugsBuild HTML5Public2018-10-29 12:59
ReporterStewart BishopAssigned ToAntanas Budvytis 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029943: Build HTML5: Splash screen png is always included in builds even if the game option is disabled
DescriptionAs the title states if you have the splash screen disabled then when you run or create an executable you'll still get the splash.png in the output folder.
Steps To Reproduce1) Create a project
2) Target HTML5
3) Run
4) Go to the temp folder for the project on disk
5) See that even though the splash screen is disabled by default the splash.png is still supplied
TagsNo tags attached.
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Russell Kay

2018-08-16 16:56

Manager   ~0061293

This is by design the image is passed to the loading screen code so that it can be used by the loading screen itself and you do not need to do any more loading at all

Dan

2018-08-24 13:05

Adminstrator   ~0061365

Last edited: 2018-08-24 13:06

View 2 revisions

This has now been changed so that we won't write out the splash screen if the game option is disabled AND there is no custom loading extension set in game options.