View Issue Details

IDProjectCategoryView StatusLast Update
00299402.x IDE BugsCode EditorPublic2018-10-25 15:46
ReporterStewart BishopAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029940: Code Editor: Copying a string in text editor and pasting into a code editor in a second IDE instance adds a new line
DescriptionWhen I copy a selection of text then paste it, there is a new line break at the end. Which seems to be handled by the IDE that the text is copied from but if you paste that into any other piece of software or another version of the IDE then you'll get a carriage return added to your string for some reason.

This means if I copy some text from one IDE and paste it in the middle of a line on another IDE or another application I have to remove the new line break which is a little inconvenient.
Steps To Reproduce1) Open up two versions of the IDE
2) Open the code editor in both
3) Write something in one version
4) Copy what you just wrote
5) Within the other IDE paste what you just copied
6) See that even though you've not copied a line return we've added one anyway
TagsNo tags attached.
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Mike Dailly

2018-08-17 11:01

Developer   ~0061295

Could not reproduce - video/gif?

Dan

2018-09-27 11:52

Adminstrator   ~0061613

The crucial bit of info was added to the description and steps - you need to copy from one IDE instance to another.