View Issue Details

IDProjectCategoryView StatusLast Update
00299112.x IDE BugsCode EditorPublic2018-10-29 10:51
ReporterStewart BishopAssigned ToSteven Campbell 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029911: Code Editor: Shader float precision doesn't get highlighted
DescriptionIf you use precision float highp then the words:

preicision
lowp
mediump
highp

Aren't highlighted and aren't in autocomplete either.
Additional InformationThere are probably more GLSL constants that we could potentially be missing but these are the first ones we noticed.
TagsIDE, Shader
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Steven Campbell

2018-08-22 15:33

Developer   ~0061337

GLSL ES added in Red IDE/GitHub Pull Request 4255 Git Id: 8fe60b8d9c8d4724e9285c9abae7349000e4112e

Steven Campbell

2018-09-05 10:25

Developer   ~0061507

GLSL defines updated in GitHub Pull Request 4272
Git Id: 3666caeb6cb3272346e00c229e7748429e111a04

Steven Campbell

2018-09-07 16:45

Developer   ~0061563

Additional update in Git Id: c7780f42a169b675d86daed08d4defea3a296282
Because I took the wrong versions.. we use GLSL 1.20 and GLSL ES 1.00