View Issue Details

IDProjectCategoryView StatusLast Update
0029897RunnerAudioPublic2021-08-03 16:59
ReporterDanAssigned ToCoreTech 
PriorityMediumSeverityC - GeneralReproducibilityUnable To Reproduce
Status ResolvedResolutionSuspended 
PlatformWindowsOSWindows 10OS VersionPro x64
Product Version2.1.4 
Target VersionFixed in Version 
Summary0029897: Audio: Some audio output devices cause the runner to take a long time to launch when doing runs of projects
DescriptionSome audio devices cause the runner to take a long time to launch when doing runs of projects (upwards of a minute has been reported in some cases) - the output log pauses on a line about gamepads, but this appears to be a red herring. *Currently*, this only seems to be an issue when doing a run/debug from within the IDE, but GMS1 and 2 are both affected. Note that audio is fine in-game; the issue is simply the long pause "during building".

In looking at customer DXDiags/ui.logs/traceIDEs, it became clear that they had either a lot of audio devices or some which looked interesting ("streaming" devices, microphones posing as audio outputs, "audio cable", etc.). For these customers we advised them to try selectively disabling these devices in Windows and seeing if this fixed the issue, and now some have confirmed this does resolve their issue.

One customer reported back that Steam's streaming service was the cause of this on their system.

Expected: Ideally, the runner only ever considers the default playback device set within Windows. Alternatively, we time-out audio devices more quickly (not sure if applicable ?).
Steps To Reproduce1. Have one of these devices.
2. Run a project on Windows.

Repro: Have not reproduced internally yet, but there are a number of tickets about this.
Tagsaudio, GMKI, Runner
1.4 Found In
2.x Runtime Found In2.1.4.218
2.x Runtime Verified In

Activities

SamH

2021-08-03 16:59

Developer   ~0066588

Unable to confirm now, as missing required device. If this still happens in the current GMS2 release, then we will investigate a fresh report. Closing.