View Issue Details

IDProjectCategoryView StatusLast Update
0029874RunnerHTML5Public2018-08-13 13:50
ReporterStewart BishopAssigned ToAlan Savage 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029874: HTML5: [GMS2] Cloned instances don't draw anything
DescriptionAfter calling the function instance_clone in HTML5 the is correctly cloned, having all the right properties, but it doesn't draw itself, nor calls the draw event.

Properties like scale, alpha, visibility, etc are all correct in the new (cloned) instance. But it is never drawn neither is the draw event ever called.

The sample/bug report project has an example of the problem, and uses instance count to show that it was actually created, and also has another object's instance to draw a mark where the cloned instance is, since it's never drawn.
Steps To Reproduce1) Run the sample in HTML5
2) Press Enter
3) See that the cloned instance doesn't draw anything
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.1.5.246
2.x Runtime Verified In

Activities

Stewart Bishop

2018-08-07 14:39

Adminstrator  

BugReportProject.yyz (120,414 bytes)