View Issue Details

IDProjectCategoryView StatusLast Update
0029861RunnerFunctionsPublic2018-10-29 12:54
ReporterStewart BishopAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029861: Functions Using texture_global_scale() then drawing text with the default font will not work
DescriptionIf you call texture_global_scale with a value of 2 for example and then attempt to draw some text using the default font then this will not work and you'll get some gibberish output instead. This seems to be caused by the fact that we don't generate a texture page when using the default font and no font resource exists inside the project.
Steps To Reproduce1) Run the sample
2) See the text
3) Create a font and set it to be used
4) Run the sample again
5) See that the issue no longer occurs
Tagsfunctions, Runner
1.4 Found In
2.x Runtime Found In2.1.5.246
2.x Runtime Verified In2.2.1.268

Activities

Stewart Bishop

2018-08-03 11:59

Developer  

default_text_texture_scale.yyz (16,122 bytes)

Russell Kay

2018-08-08 14:40

Manager   ~0061106

Fixed in gitlab