View Issue Details

IDProjectCategoryView StatusLast Update
00298592.x IDE BugsCompilingPublic2019-05-16 12:04
ReporterStewart BishopAssigned ToSteven Campbell 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029859: Compiling: Unable to compile some projects with specific sounds in them
DescriptionWith the supplied project, if you run it you'll get a smart assembly error saying "Index was outside the bounds of the array." which is seemingly caused by the sounds within the project.
Steps To Reproduce1) Run the project
2) See that it fails to compile
Repro: 100%
TagsNo tags attached.
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.0.334
2.x Runtime Verified In2.2.0.252

Activities

Stewart Bishop

2018-08-03 10:19

Adminstrator  

example.zip (338,773 bytes)

Dan

2018-08-03 11:02

Adminstrator   ~0061038

The issue is simply that for some reason these sounds are lacking any audio group information. Opening the sound editor and setting them back to the Default group (or the group of your choice) will fix, and then the project can build fine again.

We'll stop the crash and add a more useful error message here.

Peter Hall

2018-08-03 12:07

Developer   ~0061045

asset compiler crash fixed on master in commit 1f74b0c5f48efa8d9452cb01b6ab0487cec4329d

Steven Campbell

2018-08-16 10:47

Manager   ~0061269

Fixed in Red IDE GitHub Pull Request 4245
Git Id: ac35b5c0f52533dc31db70a5fe1f81d74edf8795
Cherry-Picked to Green Id: db3c4cf5e6bf129dd44b491d6141ece71b7ea979

Matthew McInnes

2018-09-05 12:30

Adminstrator   ~0061514

Closing. Verified as fixed in:

IDE v2.2.0.334 Runtime v2.2.0.252