View Issue Details

IDProjectCategoryView StatusLast Update
0029850RunnerHTML5Public2018-10-29 15:04
ReporterAntanas BudvytisAssigned ToAntanas Budvytis 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029850: HTML5: Changing background visibility in compatibility scripts does not work on code-generated backgrounds
Description__background_set( e__BG.Visible, <layer ID>, true/false) was not working correctly on backgrounds that have been created programmatically. This is due to the layer that the background belongs to being set to invisible when created. The compatibility visibility changing code needs to both alter the background element and the layer visibility to work correctly.
Steps To Reproduce1. Start GMS2.
2. Import the attached project.
3. Run it for HTML5.
4. See that the programmatically generated backgrounds (in the room creation code) are not being drawn.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In2.2.1.268

Activities

Dan

2018-08-03 11:34

Adminstrator  

bgbug.gmz (220,863 bytes)