View Issue Details

IDProjectCategoryView StatusLast Update
00298322.x IDE BugsGeneralPublic2019-05-16 12:04
ReporterSam CummingAssigned ToAlan Savage 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029832: General: [Mac IDE] Exported files do not have an extension unless you manually add the file extension
DescriptionIf you try to export a project on Mac, the resulting generated file will be missing the .yyz file extension, causing the IDE to not recognise the file (and consequently MacOS cannot associate the file with GMS2).

In addition, you cannot export Layouts correctly either, as they too are missing their file extension (.xml).

Adding the file extension manually will 'fix' the file, allowing it to be imported/opened as expected. You can also manually add the extension while setting up the destination of the export and it'll work as expected.

This appears to be all linked to Chris's changes to Mac dialog calls.
Steps To Reproduce1. Open any project on Mac.
2. Export the project.
3. Observe that the generated file does not have the .yyz file extension.
4. Add the .yyz file extension manually to the file.
5. Observe that the file is 'fixed' and you can import/open it as expected.
Additional InformationThis is Mac specific, and doesn't replicate on Windows.
TagsIDE, mac
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.0.334
2.x Runtime Verified In2.2.0.252

Relationships

related to 0029294 ClosedChris Harrison General: [Mac IDE] Finder shows no results for Add Existing in the resource tree 
related to 0029827 ClosedAlan Savage General: [Mac IDE] Unable to load Workspace layouts because Finder won't see .xml files 

Activities

Sam Cumming

2018-07-31 10:33

Developer   ~0060978

Stewart believes that this is a general thing in the Mac IDE with any exporting requiring a file extension, so exporting images from the image editor will also be missing their extensions, for example.

Sam Cumming

2018-07-31 11:11

Developer   ~0060981

And he's right, layouts don't export themselves as .xml files. Again, editing the file name to include the .xml extension will allow GMS2 to load the layout.

Matthew McInnes

2018-09-04 17:31

Adminstrator   ~0061503

Closing. Verified as fixed in:

IDE v2.2.0.334 Runtime v2.2.0.252

Both, exported projects and layouts have their associated file extension.