View Issue Details

IDProjectCategoryView StatusLast Update
00298202.x IDE BugsBuild UWPPublic2019-01-04 16:50
ReporterStewart BishopAssigned ToSteven Campbell 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformUWPOSOS Version
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029820: Build UWP: Unable to create an executable if your splash background colour is set to #000000
DescriptionIf you create a project, then by default the splash background colour is set to be #000000. However, using the current UWP SDK if you attempt to create an executable without changing this colour value you'll receive the following error:

MakeAppx : error: Error info: error C00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 28, Column 59, Reason: '#0' violates pattern constraint of '#[\da-fA-F]{6}|aliceBlue|antiqueWhite|aqua|aquamarine|azure|beige|bisque|black|blanchedAlmond|blue|blueViolet|brown|burlyWood|cadetBlue|chartreuse|chocolate|coral|cornflowerBlue|cornsilk|
crimson|cyan|darkBlue|darkCyan|darkGoldenrod|darkGray|darkGreen|darkKhaki|darkMagenta|darkOliveGreen|darkOrange|darkOrchid|darkRed|darkSalmon|darkSeaGreen|darkSlateBlue|
darkSlateGray|darkTurquoise|darkViolet|deepPink|deepSkyBlue|dimGray|dodgerBlue|firebrick|floralWhite|forestGreen|fuchsia|gainsboro|ghostWhite|gold|goldenrod|gray|green|greenYellow|
honeydew|hotPink|indianRed|indigo|ivory|khaki|lavender|lavenderBlush|lawnGreen|lemonChiffon|lightBlue|lightCoral|lightCyan|lightGoldenrodYellow|lightGreen|lightGray|lightPink|lightSalmon|
lightSeaGreen|lightSkyBlue|lightSlateGray|lightSteelBlue|lightYellow|lime|limeGreen|linen|magenta|maroon|mediumAq
uamarine|mediumBlue|mediumOrchid|mediumPurple|mediumSeaGreen|mediumSlateBlue|mediumSpringGreen|mediumTurquoise|mediumVioletRed|midnightBlue|mintCream|mistyRose|
moccasin|navajoWhite|navy|oldLace|olive|oliveDrab|orange|orangeRed|orchid|paleGoldenrod|paleGreen|paleTurquoise|paleVioletRed|papayaWhip|peachPuff|peru|pink|plum|powderBlue|
purple|red|rosyBrown|royalBlue|saddleBrown|salmon|sandyBrown|seaGreen|seaShell|sienna|silver|skyBlue|slateBlue|slateGray|snow|springGreen|steelBlue|tan|teal|thistle|tomato|transparent|
turquoise|violet|wheat|white|whiteSmoke|yellow|yellowGreen'.

The attribute 'BackgroundColor' with value '#0' failed to parse.
Steps To Reproduce1) Create a project
2) Target UWP
3) Create Executable
4) See that this fails because you've got the splash background colour set to #000000
5) Change to any other colour
6) See that this now succeeds
TagsIDE
2.x IDE Found In2.1.5.320
2.x Runtime Found In2.1.5.244
2.x IDE Verified In2.2.0.341
2.x Runtime Verified In2.2.0.258

Activities

Steven Campbell

2018-08-16 10:16

Manager   ~0061264

Fixed in Runner/GitLab Merge Request 821
Git Id: 09710f5e983918049c20036427b1b58aced8751f
Cherry-Picked to Green Id: d113b90ac23abadd46a8a5e53d5fa7965315a8cb

Dan

2018-10-01 12:30

Adminstrator   ~0061686

Works fine in IDE v2.2.0.341 Runtime v2.2.0.258. Closing.