View Issue Details

IDProjectCategoryView StatusLast Update
0029812RunnerUWPPublic2019-05-13 17:38
ReporterSam CummingAssigned ToMike Rennie 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformUWPOSXBOX OneOS Version
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029812: UWP: Pressing B on Xbox Controller when building UWP for XBox will suspend the application
DescriptionIf you press B on the Xbox Controller when you build UWP for XBox, the application will be suspended. This is due to the Runner not handling if the B button is pressed, as on UWP this fires OnBackRequested(). If this back request is unhandled, the app will be suspended, however if you handle the request then the app will remain running.

At present, any games built for XBox using UWP will suspend themselves when you press B on the Xbox Controller.

See: https://blogs.msdn.microsoft.com/chuckw/2017/12/15/directx-and-uwp-on-xbox-one/ (Game Controller Usage)
Steps To Reproduce1. Open any project.
2. Target an Xbox using UWP.
3. Build.
4. Press B on the Xbox Controller.
5. Observe as the app suspends.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.5.243
2.x Runtime Verified In9.9.1.1437

Activities

Dan

2018-09-04 14:08

Adminstrator   ~0061491

Fix is now in 2.2.0.