View Issue Details

IDProjectCategoryView StatusLast Update
00297892.x IDE BugsGeneralPublic2018-10-25 17:03
ReporterMike DaillyAssigned ToAlan Savage 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.4 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029789: General: IDE locks up when LOTS of project files change on large projects
DescriptionIf you change every file in a large project, the whole IDE just locks up as it's scanning for changes. There is no notification, and you have no idea "why" it's locked up. Eventually you'll get a list of files back that have changed, but to the end user, the IDE looks like it's locked up and crashed.
Steps To ReproduceLoad a large project
touch "every" file recursively.
IDE will lockup as it scans the project
TagsFile, IDE
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Relationships

related to 0029901 ClosedAlan Savage General: The file watcher can cause extreme amounts of IDE FPS issues within bigger projects 

Activities

Dan

2018-07-17 16:56

Adminstrator   ~0060877

Think this is what one of the interns noticed in red today - he copy/pasted a large number of moments (about 200, although the amount of code these moments contained was actually very small) from one timeline to another, and had to sit for over 5 minutes while the IDE recovered.