View Issue Details

IDProjectCategoryView StatusLast Update
0029714RunnerWindows (YYC)Public2018-10-25 16:46
ReporterYellowAfterlifeAssigned ToPeter Hall 
PriorityLowSeverityC - GeneralReproducibility<25%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=1703
Product Version2.1.4 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029714: Windows (YYC): variable_instance_get() returns undefined if there's a global variable of same name
Description
global.varname = 1;
varname = 2;
show_debug_message(variable_instance_get(self, "varname"));

outputs `undefined`
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.4.218
2.x Runtime Verified In2.2.1.268

Activities

YellowAfterlife

2018-06-25 19:11

Developer  

a_bug.yyz (46,289 bytes)

Peter Hall

2018-06-26 12:26

Developer   ~0060637

Caused by having global + local variables with the same name, fixed by giving them the same id in the ids header file.