View Issue Details

IDProjectCategoryView StatusLast Update
00296262.x IDE BugsObject EditorPublic2018-10-29 12:19
ReporterClaire HallAssigned ToAlan Savage 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029626: Object Editor: Events context menu takes several seconds to appear on large projects
DescriptionWhen opening the 'Add Event' context menu (in either the object editor's event window or the submenu command in the code editor) in a large project there is a noticeable pause of several seconds while the context menu is built.

A profile shows up 'ResourceHelper.BuildResourceContextMenu' as taking the majority of the time

Since the menu is divided up into the groups of the resource tree we could defer building the sub groups until the user hovers over them.
Steps To ReproduceOpen a large project (such as Deaths Gambit)
Use 'Add Event' from the object editor
See the delay before the IDE becomes responsive again and the context menu finally appears
TagsIDE, OtherEditor
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Alan Savage

2018-07-19 11:01

Developer   ~0060898

builds collision menu & submenus only when each menu is opened