View Issue Details

IDProjectCategoryView StatusLast Update
00295962.x IDE BugsGeneralPublic2018-10-25 16:42
ReporterStewart BishopAssigned ToRussell Kay 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformOSmacOSOS Version
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029596: General: In macOS 10.14 beta the version of Mono we rely on is deemed too out-of-date
DescriptionWithin the newest version of macOS when you attempt to use anything Mono related you'll get a warning similar to the one shown in the attached screenshots, stating this mono version needs to be updated.

We'll need to update this within the next three months so that we don't have errors when the OS update gets released.
Steps To Reproduce1) Open IDE on macOS 10.14
2) Create a project
3) Open Device Manager
4) In the iOS tab click Detect Devices
5) See the error appear
Tags221, IDE, igor, Packaging
2.x IDE Found In2.2.0.302
2.x Runtime Found In2.2.0.223
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Stewart Bishop

2018-06-05 16:52

Developer  

Russell Kay

2018-09-04 16:37

Manager   ~0061502

Fixed in gitlab - should now upgrade mono to 5.10.1.57 on install on Mac