View Issue Details

IDProjectCategoryView StatusLast Update
00295892.x IDE BugsResource TreePublic2018-09-05 15:12
ReporterClaire HallAssigned ToSteven Campbell 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029589: Resource Tree: "Add Existing" Sprite left with no texture group
DescriptionIf you use 'Add Existing' on the resource tree and choose a sprite, when you open the sprite to edit you can see that the 'texture group' drop down box is empty. We should ensure that on importing a sprite to the project that the texture group property is appropriately set.

When compiling the project with this imported sprite the asset compiler crashed due to attempting to index an array using -1

If possible we should attempt to add the sprite to a texture group of the same name as in the original project (creating one if necessary) or just add to the default group.
TagsIDE, mvc, ResourceTree
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.0.334
2.x Runtime Verified In2.1.5.247

Activities

Steven Campbell

2018-07-26 11:35

Manager   ~0060942

Fixed in Red IDE/GitHub Id: 0bbf88c4395fbc7a5d3368f2a5c644a430e44d07

Pull Request 4426

Matthew McInnes

2018-09-05 15:12

Developer   ~0061521

Closing. Verified as fixed in:

IDE v2.2.0.334 Runtime v2.1.5.247