View Issue Details

IDProjectCategoryView StatusLast Update
0029585RunnerAudioPublic2018-10-29 14:40
ReporterPeter HallAssigned ToPeter Hall 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029585: Audio: When the frame rate is set very high, audio_sound_gain() does not fade over the expected period
DescriptionThe audio fade code (Audio_SetGainForNoise) looks at g_GameTimer.GetFPS() to work out how many steps to fade out over. Since get fps is 1,000,000 it calculates a frame rate of 0 which gets bumped to 1 to avoid division by zero.

So the audio is fading out properly, but it’ll take about a day to fade all the way out.
Steps To ReproduceRun attached project, press [space] to start sound fading in.
The sound should fade in over 5 seconds, but will take longer.

If you comment out the code in object0/Alarm 0 that sets the framerate and run again it should work as designed.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In2.2.1.268

Activities

Peter Hall

2018-06-04 09:18

Developer  

audio_fade_fps_bug.yyz (3,921,422 bytes)