View Issue Details

IDProjectCategoryView StatusLast Update
0029546RunnerMacPublic2019-05-13 17:38
ReporterStewart BishopAssigned ToMike Rennie 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
PlatformMacOSOS X 10.6OS Version
Product Version2.1.4 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029546: Mac: Games crash on OS X 10.6 Snow Leopard due to missing OpenGL functions
DescriptionIf you attempt to run a game on OSX 10.6 your games will crash on startup, this is because it could not find the glGenFrameBuffers call which is caused by OSX 10.6 not handling OpenGL 3.
Steps To Reproduce1) Run any game on OSX 10.6
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.4.216
2.x Runtime Verified In9.9.1.1437

Activities

Mike Rennie

2018-09-17 14:29

Developer   ~0061583

I believe this is now fixed (I switched to using the extension versions of the framebuffer functions which should be compatible) but needs fully tested to be sure. This may also have ramifications for other OSX versions so checking across as wide a range as possible would be a good idea.