View Issue Details

IDProjectCategoryView StatusLast Update
0029438RunnerFunctionsPublic2018-09-27 17:18
ReporterStewart BishopAssigned ToAlan Savage 
PriorityHighSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Product Version2.1.4 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029438: Functions: \n doesn't break new lines in draw_text_ext_transformed() or draw_text_ext_transformed_colour() on some platforms
DescriptionIf you place a new line break in draw_text_ext_transformed() or draw_text_ext_transformed_colour(), on Windows and most other platforms this works as expected. However, on UWP, Xbox One and PS4 this \n does nothing.
Steps To Reproduce1) Run the sample on the 3 platforms mentioned above
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.4.216
2.x Runtime Verified In

Relationships

related to 0027260 ClosedRussell Kay Functions: Not correctly creating newlines for "\n" characters in the draw_text_ext function on iOS 

Activities

Stewart Bishop

2018-05-16 10:00

Adminstrator  

NewlineTest.yyz (35,747 bytes)

Stewart Bishop

2018-06-28 10:22

Adminstrator   ~0060704

This doesn't work in latest internal version so reopening.

Stewart Bishop

2018-07-02 09:50

Adminstrator   ~0060764

Turns out this also affects PS4 and XBOX One too

Alan Savage

2018-07-02 10:01

Developer   ~0060766

fix in red (runtime build scripts) 2876c2cda755210e4f4dab1224ea87837ec14e5d
YY_ZEUS was not defined (also on PS4 & Xbox VM) due to replace failing