View Issue Details

IDProjectCategoryView StatusLast Update
0029434RunnerFunctionsPublic2018-06-28 10:22
ReporterStewart BishopAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionNo Change Required 
Product Version 
Target VersionFixed in VersionInternal Build 
Summary0029434: Functions: [GMS2] game_get_speed returns the wrong value once you've set your game speed through code
DescriptionIf you set your game speed using game_set_speed then attempt to return it using game_get_speed then you'll always get 0 on every other platform than HTML5, on HTML5 you'll get Infinity as the return value.
Steps To Reproduce1) Run the attached sample on any platform
2) Press the Set FPS button
3) Confirm the dialog
4) See that this is zero or Infinity rather than whatever you set
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.4.216
2.x Runtime Verified In

Activities

Stewart Bishop

2018-05-15 16:18

Adminstrator  

FPS Test.yyz (48,423 bytes)

Russell Kay

2018-05-16 10:37

Manager   ~0059740

Not a bug - user was setting the game speed incorrectly had the parameters the wrong way round