View Issue Details

IDProjectCategoryView StatusLast Update
0029410RunnerGeneralPublic2019-05-24 09:47
ReporterStewart BishopAssigned ToMike Rennie 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionDuplicate 
Product Version2.2.0 
Target Version2.2.3Fixed in Version2.2.3 
Summary0029410: General: Changing to a persistent room or restarting a persistent room changes which layer an object is on
DescriptionPotentially due to another change we've made recently to fix another persistent issue we've now introduced a new bug in that when you restart a persistent room or change to a persistent room from another room the instances in that room are now in a different depth order and rendered differently. This is due to the fact that objects are no longer on the layer you told them to and have been sorted into a new order. If you want to use any layer functions you also can't as the layer value is always -1.
Steps To Reproduce1) Run the sample and follow on screen instructions
Tagsrendering, Runner
1.4 Found In
2.x Runtime Found In2.1.4.212
2.x Runtime Verified In2.2.3.332

Relationships

duplicate of 0027963 ClosedMike Rennie Variables: layer gets set to -1 when changing room for persistent objects 

Activities

Stewart Bishop

2018-05-04 09:34

Adminstrator  

persistent_room_issue.yyz (47,312 bytes)