View Issue Details

IDProjectCategoryView StatusLast Update
00293902.x IDE BugsCode EditorPublic2019-01-04 17:15
ReporterSam CummingAssigned ToAlan Savage 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformOSWindows 10OS Version
Product Version2.1.4 
Target Version2.1.5Fixed in Version2.1.5 
Summary0029390: Code Editor: Events 'lose' code when object name is changed but not committed
DescriptionIf you create an object with some code in it, close the event Code Editor then rename the object using the Object Editor (not the Resource Tree), the first event you open will 'lose' its code if you do not commit the object's name change (Press Enter or click anywhere other than an event).

When this behaviour occurs, it looks like the view cannot find the underlying code, and so displays nothing. Closing and reopening the event's Code Editor window will commit the name change and the code will be displayed again.

If you make changes to the now blank Code Editor window and save, the IDE will be overwrite the original code, which can result in code being lost.
Steps To Reproduce1. Create an object.
2. Create an event, fill it with some code.
3. Close the Code Editor window.
4. Rename the object in the Object Editor, don't press Enter or click anywhere else.
5. Open the event by clicking it.
6. Observe that the code is gone.
7. Close the Code Editor and reopen the event, observe that your code is recovered.
8. Repeat 4 - 6, add some new code to the now blank window and save.
9. Observe that the old code is lost.
Additional InformationThis may be a duplicate of 0027806, since it's fairly similar in nature. The whole duplication part of 0027806 may be an unnecessary step that kept throwing us off.
Tags215
2.x IDE Found In2.1.4.288
2.x Runtime Found In2.1.4.212
2.x IDE Verified In
2.x Runtime Verified In

Relationships

has duplicate 0027806 ClosedDan Saving: Duplicating an object in the resource tree sometimes fails to duplicate its events also 

Activities

Sam Cumming

2018-05-01 14:27

Developer  

bugdiscovered.gif (4,283,910 bytes)