View Issue Details

IDProjectCategoryView StatusLast Update
00293822.x IDE BugsBuild UbuntuPublic2019-01-04 17:22
ReporterSteven CampbellAssigned ToRussell Kay 
PriorityLowSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformUbuntuOSOS Version
Product Version2.1.4 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029382: Build Ubuntu: Ubuntu 18.04 cannot build YYC
DescriptionUbuntu 18.04 has now been released which we mostly work with, and should probably look into adopting as baseline support as 14.04 is now 4 years old.
I had two compile issues with YYC.

libGL had moved from /usr/lib/x86_64-linux-gnu/mesa to just /usr/lib/x86_64-linux-gnu
libcurl would not install version 3, but did install version 4 to /usr/lib/x86_64-linux-gnu/libcurl.so.4 which I was able to link against.

Additionally, I had an odd issue with the speed being halved.
I was only able to check via VirtualBox - so I wouldn't dismiss oddities there, but a VM build ran at full speed and without issue.
TagsNo tags attached.
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.1.354
2.x Runtime Verified In2.2.1.267

Activities

Russell Kay

2018-08-10 20:07

Manager   ~0061160

Fixed in gitlab

Russell Kay

2018-10-24 14:02

Manager   ~0061849

Fixed again in a better way... though we need the user to install the libcurl4-openssl-dev package as well so the full list is

build-essential
openssh-server
clang
libssl-dev
libxrandr-dev
libxxf86vm-dev
libopenal-dev
libgl1-mesa-dev
libglu1-mesa-dev
zlib1g-dev
libcurl4-openssl-dev