View Issue Details

IDProjectCategoryView StatusLast Update
00293232.x IDE BugsBuild AndroidPublic2019-05-16 12:04
ReporterSam CummingAssigned ToRussell Kay 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformAndroid YYCOSAndroidOS Version
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029323: Build Android YYC: Android YYC builds launch with error 'Unable to find library for armv7l' when using NDK 17b
DescriptionIf you target Android YYC using NDK 17b and have an older device connected, the Runner can show the following error on start: "Unable to find library for this devices architecture, which is armv7l, ensure you have included the correct architecture in your APK."

In Game Options, no architectures exist for armv7l, so I'm currently unable to build YYC for the Samsung Galaxy Tab S. I use the Tab S frequently, and it's been working so far up to the latest Red builds.

Running in VM works fine, this only affects YYC builds.
Steps To Reproduce1. Target Android YYC on an Android device.

Build Tools: 27.0.0
Support Library: 27.0.0
Target SDK: 27
Minimum SDK: 14
Compile SDK: 27
NDK: 17.0.4754217

2. Enable only Arm7, Arm64 and x86_64 architectures for Android
3. Build to the device.
4. Observe the above error when the runner launches.
TagsNo tags attached.
2.x IDE Found In9.2.1.1399
2.x Runtime Found In9.9.1.1003
2.x IDE Verified In2.2.0.334
2.x Runtime Verified In2.2.0.252

Activities

Russell Kay

2018-05-01 15:36

Manager   ~0058939

Last edited: 2018-05-01 15:39

View 3 revisions

Unable to reproduce on red IDE 9.2.1.1379 and Runtime v9.9.1.965 - Build Tools were set to 23.0.1, Support Library 23.1.1, Target SDK 23, Minimum SDK 9, Compile SDK 23 - I am using NDK 16b

Sam Cumming

2018-05-01 16:04

Developer   ~0058941

I'll see if I can take a deeper look at this soon and get more accurate repro-steps.

Sam Cumming

2018-07-16 10:48

Developer   ~0060862

Last edited: 2018-07-16 10:48

View 2 revisions

Replicated > 2.1.5.319 / rt 2.1.5.243 - Updating repro-steps - I've managed to get this again on both the Tab S and an Amazon Fire device (while building Android), with the Armv7, Arm64 and x86_64 architectures selected. Again, this only happens in YYC, VM is not affected - Reopening.

Russell Kay

2018-07-18 09:53

Manager   ~0060890

I could not get this to happen, I suspect it has something to do with which SDK, NDK or even which project you are using, we need more info to replicate

Sam Cumming

2018-07-23 09:59

Developer   ~0060915

Last edited: 2018-07-23 10:00

View 2 revisions

Build Tools: 27.0.0
Support Library: 27.0.0
Target SDK: 27
Minimum SDK: 14
Compile SDK: 27
NDK: 17.0.4754217

Architectures: Armv7, Arm64, x86_64.
The device I'm using supports Armv7 (Fire HD 10 5th Gen)

Russell Kay

2018-08-01 22:05

Manager   ~0061013

Fixed in gitlab

Sam Cumming

2018-08-07 09:37

Developer   ~0061066

If you're using NDK 17, you'll encounter this issue on older devices (non-64bit architectures). Use NDK 16 instead for now as a workaround.

Dan

2018-08-31 09:33

Adminstrator   ~0061413

We do have some reports that using 16b can still reproduce this error. It appears that if you have 17b+ installed, but not in use in game options (you're using 16), this can still cause errors.

Dan

2018-08-31 09:36

Adminstrator   ~0061414

This issue is seemingly specific to devices which use Android API 23 (Android 6.0 - Marshmallow). That version of the OS did not ship with the support libraries installed on the device and the latest NDKs have stopped including support for them also.