View Issue Details

IDProjectCategoryView StatusLast Update
00292992.1 IDE Bugs [2.x IDE Bugs] Variables WindowPublic2018-04-18 11:37
ReporterSam CummingAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version[2.x IDE Bugs] 2.1.4 
Fixed in Version[2.x IDE Bugs] 2.1.4 
Summary0029299: Variables Window: 'image_blend' is 0 when assigned a colour from Variable Definitions
DescriptionIf you try to assign a colour to image_blend that's been defined in Variable Definitions, image_blend becomes 0. This may be because the colour's alpha value is being assigned also, which image_blend doesn't expect.
Steps To Reproduce1. Open any project.
2. Create a sprite.
3. Create an object, assign that sprite to it.
4. In the object's Variable Definitions, create a colour (any colour is fine) called DisabledImageBlendColour.
5. Add a Draw event to the object.
6. Insert the following code: image_blend = self.DisabledImageBlendColour
7. Debug.
8. Observe that image_blend is 0 after being assigned a colour.
2.x IDE Found In2.1.4.288
2.x Runtime Found In2.1.4.203
2.x IDE Verified In
2.x Runtime Verified In

Activities

Sam Cumming

2018-04-11 14:45

Adminstrator  

ImageBlendBug.yyz (33,604 bytes)

Daniel Cleaton

2018-04-18 10:54

Adminstrator   ~0058764

Will be in runtime 204+.