View Issue Details

IDProjectCategoryView StatusLast Update
0029293RunnerRoomsPublic2018-04-18 11:00
ReporterStewart BishopAssigned ToPeter Hall 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.4 
Target Version2.1.4Fixed in Version2.1.4 
Summary0029293: Rooms: [GMS2] Room Persistence causes collision issues with instances that don't exist in the new room
DescriptionWhenever I want to change rooms from a room that was labeled persistent, my game acts as if the instances from the room are still there, even though:

1. I'm no longer in the previous persistent room
2. The objects of the instances in the previous persistent room aren't persistent themselves
3. The instances of the previous persistent room aren't even being shown on screen.

It's as if the ghost of the previous room was still in my game. The issue was fixed when I turned the room's persistence off, but I never had this issue until installing the most recent update.
Steps To Reproduce1) Run the sample
2) Collect all the keys on screen using WASD
3) Go to the door with the 3 key symbol
4) Proceed through the gate
5) Keep going up with S since gravity is reversed now for some reason
6) Once you collide with something you'll be able to move around with WASD again
7) Move to the walls and you'll see that you're colliding with instances which don't exist
TagsGMKI
1.4 Found In
2.x Runtime Found In2.1.4.202
2.x Runtime Verified In

Activities

Peter Hall

2018-04-11 16:31

Developer   ~0058700

when leaving a persistent room, delete the collision tree. when entering one, rebuild it.
otherwise all those things sit in the collisions tree messing things up for the other rooms.

Dan

2018-04-18 10:54

Adminstrator   ~0058768

Will be in runtime 204+.