View Issue Details

IDProjectCategoryView StatusLast Update
0029284RunnerGeneralPublic2018-08-03 11:44
ReporterStewart BishopAssigned ToPeter Hall 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.4 
Target Version2.1.4Fixed in Version2.1.4 
Summary0029284: General: Fast Collisions floor floating point values rather than ceil them which Slow Collisions do, causes changes in gameplay
DescriptionIn 2.1.3 if you did a check on an object at 0.7, 0.7 then this would become 1, 1 which users have built their games to do however with the addition of fast collisions then 0.7, 0.7 becomes 0, 0 and so there's noticeable differences in gameplay.

We need to either clarify whether this is a bug we've intended to introduce and message out or something we need to fix.
Steps To Reproduce1) Run the sample in 2.1.3 Runtime
2) See that the values gets ceiled
3) Run the sample in 2.1.4 Runtime
4) See that the values get floored
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.4.202
2.x Runtime Verified In

Activities

Stewart Bishop

2018-04-09 15:10

Adminstrator  

CollisionProblemSample.yyz (14,336 bytes)

Peter Hall

2018-04-11 10:47

Developer   ~0058682

turned on fast collision compatibility mode for zeus projects
otherwise we were flooring bounding box positions rather than rounding them

Dan

2018-04-18 10:54

Adminstrator   ~0058769

Will be in runtime 204+.