View Issue Details

IDProjectCategoryView StatusLast Update
0029256RunnerHTML5Public2018-04-11 17:28
ReporterYellowAfterlifeAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=1703
Product Version 
Fixed in Version 
Summary0029256: HTML5: camera_set_view_angle has clipping and backbuffer clearing issues
DescriptionRun the example and use mouse to move the green instance and A/D keys to rotate the view.

If view rotation is 5..15 degrees, moving the green instance to screen corners will produce persistent marks because nothing is drawn there.

If view rotation is >80 degrees, instance sprites start to clip out even if they are in the middle of the view.

from forum: https://forum.yoyogames.com/index.php?threads/change-view-angle-in-html-bug.45319/
1.4 Found In
2.x Runtime Found In9.2.1.1376
2.x Runtime Verified In

Activities

YellowAfterlife

2018-04-02 18:16

Developer  

a_bug.yyz (24,896 bytes)
png3.png (15,954 bytes)
png3.png (15,954 bytes)
png4.png (10,100 bytes)
png4.png (10,100 bytes)

Mike Rennie

2018-04-11 17:28

Developer   ~0058702

Fixed in gitlab