View Issue Details

IDProjectCategoryView StatusLast Update
0029203RunnerExtensionsPublic2018-10-29 16:14
ReporterYellowAfterlifeAssigned ToAlan Savage 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS VersionPro 1703+
Product Version2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029203: Extensions: GML scripts aren't always added to script list
DescriptionAn interesting thing. In GMLive, I ran into issues with extension script IDs sometimes pointing to a wrong script (seemingly dependent on order of inclusion of extensions). So I have made a workaround (filling up a ds_map with script_get_name -> script index data in a loop) and that worked fine.

This weekend I've been trying to get it to work on HTML5 (again), but found that GML extension scripts are never added to Scripts/ScriptNames arrays in game JSON. Making a test project with an extension (attached), I've found that for it the extension scripts aren't considered as "real" scripts even on native builds.

Ability to reference/call extension scripts was introduced relatively recently but something is very off with this feature.
Tags221
1.4 Found In
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In2.2.1.269

Activities

YellowAfterlife

2018-03-26 08:33

Developer  

a_bug.yyz (55,297 bytes)

Alan Savage

2018-06-19 09:17

Developer   ~0060448

+ 928e503895ffb9f8b4ac629fd69741313c73382a
only issue here was that asset_get_index(), script_exists(), script_get_name(), script_execute were not working for extension functions - for native the reason is that the extension is not included if no functions are explicitly called, this is as intended; the fix is for html5 where these calls would never work for extension functions.
sample will now work for html5 as is, for native an explicit extension function call or init function must be included to pull in the extension