View Issue Details

IDProjectCategoryView StatusLast Update
00291892.x IDE BugsUIPublic2019-01-04 16:29
ReporterSam CummingAssigned ToAlan Savage 
PriorityMediumSeverityText/TypoReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.4 
Target Version2.2.1Fixed in Version2.2.1 
Summary0029189: UI: [Mac IDE] "Laptop Mode" tooltip shows instructions for use on Windows machines
DescriptionThe tooltip for the Laptop Mode button on Mac doesn't show Mac specific keys, and instead shows instructions for use on Windows machines.

There is no 'Right Ctrl' on Mac, so we should instead refer to 'Right Command'.
Steps To Reproduce1. Open any project on Laptop.
2. Hover over the Laptop Mode button in toolbar.
3. Observe tooltip.
TagsNo tags attached.
2.x IDE Found In2.1.4.276
2.x Runtime Found In2.1.4.192
2.x IDE Verified In2.2.1.347
2.x Runtime Verified In2.2.1.262

Activities

Chris Harrison

2018-03-23 08:06

Developer   ~0058321

Last edited: 2018-03-23 08:07

View 2 revisions

english.csv has two new strings:

$win_LaptopRHSKeys,Right Control and Right Alt,Right Control and Right Alt,,Windows version of laptop mode keys
$mac_LaptopRHSKeys,Right Command and Right Alt,Right Command and Right Alt,,Mac version of laptop mode keys

And IDETooltip_LaptopMode_Description has been altered accordingly.

Other languages will need updating similarly.

Russell Kay

2018-05-22 15:55

Manager   ~0059921

This looks like it is fixed

Matthew McInnes

2018-06-21 17:07

Developer   ~0060554

Reopening. As of:

GREEN (309)
RED (1460)

The tooltip still refers to 'left control' rather than 'left command'.

See attached screenshot.

Matthew McInnes

2018-06-21 17:07

Developer  

Matthew McInnes

2018-10-17 14:20

Developer   ~0061789

Closing. Verified as fixed in:

IDE v2.2.1.347 Runtime v2.2.1.262