View Issue Details

IDProjectCategoryView StatusLast Update
0029157RunnerSpinePublic2019-02-26 16:12
ReporterStewart BishopAssigned ToMike Rennie 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0029157: Spine: Using skeleton_collision_draw_set() whilst a shader is set stops collision boxes being rendered and throws errors
DescriptionWhen using a Spine sprite, drawing it by using the default pass through shader (or any shader) that GMS2 creates disables the functionality of the skeleton_collision_draw_set() function and no collisions boxes are drawn at all.

It also gives a single error message in the console:
"Could not generate input layout (is there a mismatch between your shader and vertex format?)

and then proceeds to spam another message every frame, which is:
"Draw failed due to invalid input layout"

Removing the call to skeleton_collision_draw_set() stops the message from appearing.
Steps To Reproduce1) Run the sample
2) See the errors
3) Within the create event of the object comment out the call to skeleton_collision_draw_set(true);
4) Run again
5) See that errors no longer appear
TagsRunner, Spine
1.4 Found In
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2018-03-15 16:17

Developer  

Spine.yyz (172,750 bytes)