View Issue Details

IDProjectCategoryView StatusLast Update
0029133RunnerWindowsPublic2018-05-11 14:26
ReporterSam CummingAssigned ToChris Harrison 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionWon't Fix 
PlatformWindowsOSOS Version
Product Version2.1.3 
Target VersionFixed in Version 
Summary0029133: Windows: url_open() should use Windows' "Default Browser" setting, not the .html file association
DescriptionThe runner will use the user-specified default HTML Editor instead of the Default Browser when dealing with HTML/HTTP functions.

If you select a HTML file, right click it, and set the default program for opening to be a non-Browser application, the Runner will open that application when a HTML/HTTP function is called.
Steps To Reproduce1. Open the attached project.
2. Find a HTML file on your system and set its Default 'Open With' to a non-Browser application, such as Notepad.
3. Run for Windows.
4. Observe that the application you specified is opened when url_open() is encountered.
5. Reset your default Open With to a browser.
6. Run for Windows.
7. Observe that the browser opens and takes you to the YoYo Games website.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In

Activities

Sam Cumming

2018-03-13 10:26

Developer  

140364Confirm.yyz (19,157 bytes)

Dan

2018-03-14 09:18

Adminstrator   ~0058213

Last edited: 2018-03-14 09:23

View 3 revisions

url_open() has always just called whatever handling application Windows has registered for the protocol requested (http, https, mailto, etc.). So this is as expected. Otherwise, it would need to search your hard drive for the install location of the specific browser or e-mail client you intended to be opened on your machine, and it can't do that.

We should update the manual page for url_open() to explicitly state this, as right now it does just say "your browser" will be opened.

Dan

2018-03-14 09:29

Adminstrator   ~0058214

Actually, Windows 10 at least *does* have a separate setting for what is your default browser and what is your default mail client, so it should actually be possible to now just query and use this instead.

Russell Kay

2018-05-11 14:26

Manager   ~0059557

Unfortunately we have been round the houses with this and what we currently have appears to be the best of a profoundly bad Windows setup world out there with lots of misconfigured machines - this will do the correct thing for most protocols across the most machines.

We have tried many permutations and this method works best that we can see from our support calls.