View Issue Details

IDProjectCategoryView StatusLast Update
0028957RunnerFunctionsPublic2018-04-13 16:20
ReporterSam CummingAssigned ToChris Harrison 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionFixed 
Product Version2.1.3 
Fixed in Version 
Summary0028957: Functions: 'Instance_Change()' can duplicate objects into 1000s after 4 or 5 calls
DescriptionIf you use the 'Instance_Change()' function, then execute some code on the changed instance, then change back to the original instance again (using Instance_Change), you will duplicate the original object exponentially, very quickly reaching 1000s of Instances. This leads to the Runner becoming unstable and unresponsive.

In the attached project, if you open o_fox, you'll see that it calls Instance_Change(o_blank, true), and then in o_blank it modifies the position of the object before changing back to o_fox.

The attached project also has a workaround for the bug. According to the workaround, this behaviour only occurs when Instance_Change is called in the Create event. Moving the function to any other event will stop this bug from replicating.
Steps To Reproduce1. Open the attached project.
2. Open o_fox and o_blank, observe that these objects swap between each other when left mouse is pressed.
3. Run the project.
4. Click multiple times, observe that the Instance count rapidly climbs, even though it shouldn't.
Additional InformationThe reporter mentions that this has been occurring since 2.1.0.135.
1.4 Found In1.4.17
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In

Activities

Sam Cumming

2018-02-21 09:24

Adminstrator  

Instance Change.yyz (27,150 bytes)

Chris Harrison

2018-04-13 16:20

Developer   ~0058711

...actually fixed 9 days ago. It concerns me that I've resolved the wrong bug as fixed then!