View Issue Details

IDProjectCategoryView StatusLast Update
00288542.x IDE BugsSound EditorPublic2018-10-19 12:12
ReporterStewart BishopAssigned ToSteven Campbell 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0028854: Sound Editor: Renaming a sound which is paused doesn't work and resets the name
DescriptionIf you play a sound, pause it and then rename it this will work for the very first time. However, if you then repeat these steps, no matter what you do it will rename everything back to the new name of the sound you just renamed.

Expected would be that if a sound is playing or paused you can't rename it at all, as FFMPEG will have a lock on this file and will cause issues until the lock has been removed.
Steps To Reproduce1) Create a sound
2) Add in a sound
3) Start playing
4) Pause it
5) Rename it
6) Play it
7) Pause it
8) Rename it
9) See that this failed
Tagsaudio, IDE, other_editor
2.x IDE Found In2.1.3.273
2.x Runtime Found In2.1.3.189
2.x IDE Verified In2.2.1.347
2.x Runtime Verified In2.2.1.262

Activities

Steven Campbell

2018-07-25 14:53

Manager   ~0060938

Checked in current 2.1.4 and could not reproduce
I suspect this has already been fixed.

Sam Cumming

2018-08-16 16:13

Developer   ~0061288

Replicated > 9.2.1.1514 / rt 9.9.1.1139 - Attached a project that shows this issue - Reopening.

Sam Cumming

2018-08-16 16:14

Developer  

cantchangesound.yyz (27,244 bytes)

Steven Campbell

2018-08-22 15:34

Manager   ~0061339

Fixed in Red IDE/GitHub Pull Request 4255
Git Id: 1f11caf3be9f2612e7b52383e6b5a3fab2176266

Matthew McInnes

2018-10-19 12:12

Adminstrator   ~0061802

Closing. Verified as fixed in:

IDE v2.2.1.347 Runtime v2.2.1.262