View Issue Details

IDProjectCategoryView StatusLast Update
00288372.1 IDE Bugs [2.x IDE Bugs] Build iOSPublic2018-04-06 14:25
ReporterStewart BishopAssigned ToChris Harrison 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformiOSOSOS Version
Product Version[2.x IDE Bugs] 2.1.3 
Fixed in Version[2.x IDE Bugs] 2.1.4 
Summary0028837: Build iOS: Unable to build projects with short names, e.g. "p2"
DescriptionI created a project named "p2".. Building for iOS fails in a strange way, launching Xcode with a non-existent xcodeproj path.. the xcodeproj does get created in one of the intermediary folders.

Eventually I noticed this "p_2" folder in various spots and decided to make a new project with a different name, then iOS worked fine.

My assumption is that the name "p2" itself causes a failure in export.

cd /Users/Stewart/GameMakerStudio2/iOS/GMS2IOS/p2/p_2; open -a '/Applications/Xcode.app' p_2.xcodeproj;

System.Exception: Error running command 'cd /Users/Stewart/GameMakerStudio2/iOS/GMS2IOS/p2/p_2; open -a '/Applications/Xcode.app' p_2.xcodeproj; '


   at ..(String , String , Boolean )
   at ..(String , String , String , Boolean , String , String , String , String , Boolean , String , YYDictionary`2 , String , String )
   at Igor.iOSBuilder.Run()Igor complete.
elapsed time 00:00:14.1861065s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.1.3.189/bin/Igor.exe" -options="D:\IDE\Studio2\GMS2TEMP\build.bff" -- iOS Run started at 02/05/2018 12:37:14
Steps To Reproduce1) Create a project named p2
2) Run it on iOS
3) See the above error
2.x IDE Found In2.1.3.273
2.x Runtime Found In2.1.3.189
2.x IDE Verified In
2.x Runtime Verified In

Relationships

has duplicate 0028897 ClosedRoss Manthorp Runner iOS: Building for iOS will get stuck and never complete if project name starts with numbers 

Activities

Stewart Bishop

2018-03-14 14:59

Adminstrator   ~0058233

Working as intended now.