View Issue Details

IDProjectCategoryView StatusLast Update
00288192.x IDE BugsSprite EditorPublic2018-06-15 14:23
ReporterStewart BishopAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.3 
Target Version2.1.4Fixed in Version2.1.4 
Summary0028819: Sprite Editor: Importing GIFs from Asesprite has traces of other frames in them
DescriptionWhen importing to GMS2 an animated GIF file made in the pixel art program Aseprite, some of the frames sometimes retain "traces" of previous frames at their edges, as if a small border around the file was not clearing its background color properly, or was imported wrong somehow. The size of the border seems to vary, sometimes being just one pixel wide, sometimes more.

Loading the file in another program shows no problems. and the file seems to display properly in any other context. Also, if I load the gif file in a program like Graphicsgale and then save it again, it now loads properly in Game Maker. So it seems like there is some strange incompatibility between GIF files saved a certain way, and GMS2's sprite importing.

I have linked a zip file containing two versions of the same gif animation of several food icons, one made in aseprite, and one loaded and then saved in graphicsgale. Import both files as GMS2 sprite resources to see the difference.

It's not clear if its a problem with Aseprite or Game Maker Studio, but since other programs appear to display the images properly, there must be something wrong with how they are loaded in GMS2? Maybe that a certain way Aseprite automatically handles lossless GIF compression is unsupported by GMS2?
Steps To Reproduce1) Create a project
2) Import both gifs
3) See the one from Asesprite has the issue stated
TagsNo tags attached.
2.x IDE Found In2.1.3.273
2.x Runtime Found In2.1.3.189
2.x IDE Verified In2.1.4.294
2.x Runtime Verified In2.1.4.216

Activities

Stewart Bishop

2018-02-01 15:38

Adminstrator  

gifIcons.zip (3,860 bytes)

Alan Savage

2018-02-13 10:31

Developer   ~0057702

Added implementation for unusual "Dispose to previous" disposal method used by example gif, which now display correctly in GMS2.

Matthew McInnes

2018-05-14 15:48

Adminstrator   ~0059688

Closing. Verified as fixed in:

IDE v2.1.4.294 Runtime v2.1.4.216