View Issue Details

IDProjectCategoryView StatusLast Update
00287842.x IDE SuggestionsGame OptionsPublic2018-08-29 16:29
ReporterSteven CampbellAssigned To 
PriorityNoneSeveritySuggestionReproducibilityN/A
Status NewResolutionOpen 
Summary0028784: Suggestion: Game Options: Build Options should be one gadget to facilitate value-checking for both Android and Amazon
DescriptionThe build options for both Android and Amazon Fire are currently separate option values, which cannot communicate with each other. If we combine them into the one gadget, we can then check for compatibility between the values - such as ensuring the user doesn't select a target SDK which is too old to support their chosen Support Library - and flag it up.

Ideally, we'd also add the ability to upgrade the user's SDK from here as well.
Steps To ReproduceGo to Android Options.
Select an API Level from the combo box and see we populate with compatible values.
Change the Compile SDK to 1
Try and build
See that it lets you but the build fails.
TagsNo tags attached.

Relationships

related to 0025340 ClosedSteven Campbell 2.x IDE Bugs Build Android: [Android SDK 25.2.3+ has no separate "Support Library" package so we should see about removing option for it] 

Activities

There are no notes attached to this issue.