View Issue Details

IDProjectCategoryView StatusLast Update
0028631RunnerWindows (YYC)Public2018-01-08 09:56
ReporterStewart BishopAssigned ToMike Dailly 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionNo Change Required 
PlatformWindows (YYC)OSOS Version
Product Version 
Fixed in Version 
Summary0028631: Windows (YYC): Building for YYC flips normals and texture coordinates
DescriptionWithin the attached sample if you enable gml_release_mode or build for YYC then the model will have its normals and UVs flipped causing it to not be rendered correctly.
Steps To Reproduce1) Within o_main comment out the gml_release_mode line
2) Run the project on YYC
3) See that it is rendered incorrectly
4) Run it again on VM
5) See that it is now working as expected
1.4 Found In1.4.1773
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In2.1.3.189

Activities

Stewart Bishop

2018-01-05 14:09

Adminstrator  

3DProblem.gmz (305,520 bytes)
3DProblem.jpg (988,740 bytes)

Mike Dailly

2018-01-08 09:56

Manager   ~0057196

Not a bug.

In release mode, and YYC vertex data must be filled in IN ORDER.

Format was... vertex,normal,texture,colour.
Data was written.... vertex,texture,normal,colour.

This will not change as it's a major performance hit NOT to write in order.