View Issue Details

IDProjectCategoryView StatusLast Update
0028598RunnerExtensionsPublic2018-01-12 13:47
ReporterChris LeeAssigned ToSam Cumming 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionNo Change Required 
Product Version 
Fixed in Version 
Summary0028598: AmazonGameCircle extension and IAPs do not seem to work in GMS2
DescriptionI wasn't able to get them to work until I modified the extension .yy file in the extension folder to update the "classname" setting in each extension. Documented here :

https://forum.yoyogames.com/index.php?threads/amazon-gamecircle-extension.39979/

Additionally, I wasn't able to remove the AmazonGameCircle and IAP extension from the COPY TO of the DEFAULT config and have it still work on another "Amazon" config which did have the Copy To properly set for the extension. I had to leave it checked in the default config, only then the Amazon config would build as expected.



Steps To Reproduce1) Include AmazonGameCircle and IAP extensions in project. Build, and check log to see that the extensions fail to initialize with the methods not being found.
2) Alter the .yy extension files as documented in the above link.
3) Rebuild, to see the extensions initialize properly.
1.4 Found In1.4.17
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In

Activities

Daniel Cleaton

2018-01-04 09:15

Adminstrator   ~0057167

We'll look into this of course, Chris, but be aware everyone's ability to report directly to Mantis will be removed in the next few days. (You will still be able to see reports as a guest user.)

Use the form at wwww.yoyogames.com/bug to send us reports going forward.

Thanks for all of your contributions!

Sam Cumming

2018-01-11 16:10

Adminstrator   ~0057288

Update from Chris Lee via Helpdesk:

I got Amazon IAP to work. The classname being empty does throw an exception, but it doesn't seem to affect the IAP from working. It doesn't seem to be a bug.

What DOES seem to be a bug is the way that configurations are currently working. I cannot successfully separate an AMAZON config from the DEFAULT config and have them both utilize extensions indpendantly. That is, have an extension exclusively in one config and not the other. The manifest from any extension "ticked off" in DEFAULT always gets included in the other configs. Right now, I have to manipulate the DEFAULT config each time I build for Amazon and again for Google Play.

Sam Cumming

2018-01-12 13:46

Adminstrator   ~0057301

Closing since original reporter has clarified that this isn't a bug.